Categories
Google Web Browsers

Google urges users to install security updates for Chrome browser

Google has requested that its Chrome browser be updated as soon as possible due to a security vulnerability logged as CVE-2019-5786.   Users should make certain that the installed Chrome version is 72.0.3626.121 or higher.